Home > An Error > An Error Occurred While Installing Pg 0.17.1

An Error Occurred While Installing Pg 0.17.1

I fixed it with replacing the value of build.pg to: bundle config build.pg --with-pg-config=/usr/local/Cellar/postgresql/9.4.4/bin/pg_config which is where my postgresql installation is. Could not find gem 'pg (>= 0) ruby' in any of the gem sources listed in your Gemfile or installed on this machine. –phd May 11 '15 at 8:46 Thank you, stranger. I also tried changing the production setting the database.yml file to postgresql, which also doesn't help. navigate here

Thank you. –JohnSalzarulo Oct 17 '14 at 17:02 @JohnSalzarulo - Glad it helped :) –Ali Yazdani Oct 17 '14 at 18:57 Thank You. Also tried a rbenv rehash also and executed the above commands and have had no luck. What's the fastest way to generate a 1 GB file containing only random numbers? Learning ruby/rails? http://stackoverflow.com/questions/20754081/an-error-occurred-while-installing-pg-0-17-1-and-bundler-cannot-continue

Is there any way to use a sub-domain as your root domain Differences between Interrupts and sampling for hardware button? What to fill under occupation if you have quit your job How can I generate voltage for a science project? Zeroes of a not quite holomorphic (but random if helpful) function Coworkers quitting under special circumstances -- should telling our manager be one of my options? I have tried to install the pg gem and postgres.app.

What's the fastest way to generate a 1 GB file containing only random numbers? Which current networking protocol would be the optimal choice for very small FTL bandwidth? Java Scanner Class bad character "®" Can I brine meat after cooking it? Make sure that `gem install sdoc -v '0.4.1'` succeeds before bundling0bundle install --without production remediates error, but why? ( Make sure that `gem install pg -v '0.18.1'` succeeds before bundling)0gem install

What is the role of conjectures in modern mathematics? How to politely decline compensation? How worried should I be about getting hacked with PoisonTap? http://stackoverflow.com/questions/20677206/installing-pg-v-0-17-1 TryRuby in your browser Try RubyKoans to learn more about syntax, structure, and common functions and libraries Hackety Hack is a shoes app for playing around with ruby Learning Rails?

more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed asked 3 years ago viewed 70188 times active 17 days ago Blog How We Make Money at Stack Overflow: 2016 Edition Upcoming Events 2016 Community Moderator Election ends in 5 days Precompiling assets failed. ! ! If the co-signer on my car loan dies, can the family take the car from me like they're threatening to?

Ulises Reyes 9,002 Points Ulises Reyes Ulises Reyes 9,002 Points almost 3 years ago Thanks. Invalid CSS after "...":3,"sources":[": expected "|", was ""less/theme.les..." (in /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/app/assets/stylesheets/application.css) (sass):367 /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:1147:in `expected' /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:1085:in `expected' /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:1080:in `tok!' /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:785:in `attrib_name!' /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:753:in `attrib' /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:672:in `simple_selector_sequence' /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:646:in `_selector' /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:619:in `selector' /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:603:in `selector_sequence' /tmp/build_45fc5abd-fc60-4963-b8fa-d1d5cbdefe61/vendor/bundle/ruby/2.0.0/gems/sass-3.2.13/lib/sass/scss/parser.rb:528:in `ruleset' Did the Gang of Four thoroughly explore "Pattern Space"? Jan 18 08:08:38 localhost.localdomain systemd[1]: postgresql.service: control process exited, code=exited status=1 Jan 18 08:08:38 localhost.localdomain systemd[1]: Failed to start PostgreSQL database server.

Why \rm in math mode works in some tex editors and not in others? 5 Favorite Letters Multiplication Formatting How does Professor McGonagall know about the Golden Trio's conversation? check over here share|improve this answer edited Feb 4 at 0:48 Ilya Cherevkov 664828 answered May 12 '15 at 5:50 phd 1481110 add a comment| up vote 4 down vote If you are using share|improve this answer answered May 11 '15 at 10:11 kartik 389111 add a comment| up vote 10 down vote If you are not sure where your pg_config is, and assuming you It took me 10 minutes to figure that out the hard way. –tir38 May 12 '14 at 1:13 2 worked for 14.04! –Cobbles Jul 23 '14 at 17:49 3

Did you simply use: rails new *appname* If so maybe try creating a new rails app like so: rails new *appname* -d postgresql And before you create your database and run Why is nuclear waste more dangerous than the original nuclear fuel? I've forgotten the significance of this, but it basically allows the gem to run natively on the OS environment you're using. http://focalhosting.com/an-error/an-error-occurred-while-installing-evolve.html test: adapter: sqlite3 database: db/test.sqlite3 pool: 5 timeout: 5000 production: adapter: sqlite3 database: db/production.sqlite3 pool: 5 timeout: 5000 Include the following in your Gemfile: group :development, :test do gem 'sqlite3' end

How does the Mac SE/30 send video to the analog board? Finding The nth Prime such that the prime - 1 is divisible by n Word association: Guess the movie title 2! thank you –Uri Klar Sep 24 '14 at 6:27 Actually, I need this every time I run bundle install so I've put it inside ~/.bash_profile as an export :)

Did the Chinese population really resort to cannibalism during the reign of Mao?

Make sure that `gem install rack -v '2.0.1'` succeeds before bundling3gem install pg for ruby on rails Hot Network Questions Is every non stationary series convertible to a stationary series through This is what you need to do for Mint. permalinkembedsavegive gold[–]ExNihil[S] 0 points1 point2 points 1 year ago(0 children)Yep. :-( permalinkembedsaveparentgive gold[–]Misaiato 0 points1 point2 points 1 year ago(1 child)You do have Postgresql itself installed first, right? of D&D?

If building fails, please try again with --with-pg-config=/path/to/pg_config checking for libpq-fe.h... no Can't find the 'libpq-fe.h header *** extconf.rb failed *** Could not create Makefile due to some reason, probably lack of necessary libraries and/or headers. You may need configuration options. http://focalhosting.com/an-error/an-error-occurred-while-installing-half-life-dedicated-server.html current community chat Stack Overflow Meta Stack Overflow your communities Sign up or log in to customize your list.

When we run gem install pg -v '0.18.2', we also get an error: Building native extensions.

© Copyright 2017 focalhosting.com. All rights reserved.